Tag Archives: Leica M9 corrosion issue

Update on the Leica CCD sensor issue for the Leica M9/M9-P/M-E/M Monochrom cameras

Leica published a new update on the Leica CCD sensor issue for the Leica M9, M9-P and M-E cameras – they have successfully developed a new generation of CCD sensors and will begin replacing the sensors in models that were affected by corrosion with sensors from the new generation. Here is the full text:

Posted in Leica M, Leica M-E | Tagged | Comments closed

Update on the Leica CCD sensor issue for the Leica M9/M9-P/M-E/M Monochrom cameras

Leica published an update on the Leica CCD sensor issue for the Leica M9, M9-P, M Monochrom and M-E cameras, but then the release was removed is now available on their website just like the M 240 firmware update from 2 weeks ago. Leica states that they are currently working on a “new generation of sensors” and “will […]

Posted in Leica M | Tagged | Comments closed

Leica offering a trade-up program for defective M9/M9-P/M-E cameras

Leica officially announced a trade-up program for defective M9/M9-P/M-E cameras that have the white spots/corrosion issue I reported few weeks ago. I uploaded the trade-up form on Facebook. Here are the details from Leica Store Miami:

Posted in Leica M | Tagged | Comments closed

Leica Camera’s official response on the M9 sensor white spots/corrosion issue

Leica Camera has issued an official statement on the Leica M9 sensor white spots/corrosion issues I reported earlier:

Posted in Leica M-E, Leica M9, Leica M9-P | Tagged | Comments closed

Leica M9 sensor white spots/corrosion issues reported

For the past few weeks l-camera-forum members have been reporting strange white spots/corrosion issues on Leica M9 cameras – see this and this thread for more details. Similar problems have also been reported for the M9-P, M-E and M Monochrome models. The white spots are probably due to corrosion on the top cover glass (Schott S8612) of […]

Posted in Leica M-E, Leica M9, Leica M9-P | Tagged | Comments closed